返回列表 发帖

TY00D0021211KC NAND

你好,

我有兴趣从贵司购买TL866 II Plus或者XGecu T56编程器。

我需要读取一枚东芝TY00D0021211KC NAND闪存芯片的内容。该芯片使用BGA149封装,是<1GB(?) 16位的SDR NAND。我未能找到该芯片的完整规格书,仅有引脚图。

根据贵司网站上所列支持的NAND芯片列表,该芯片并未支持。然而如果存在与此相似的芯片在支持列表中的话,请问贵司的软件是否支持手动配置访问参数?

综上所述,请问我应购买哪一款编程器,能够支持该东芝芯片?

非常感谢。

=============================================================================================
Hello,

I am considering purchasing the TL866 II Plus or XGecu T56 programmer.

I need to read out a Toshiba TY00D0021211KC NAND flash chip, which is in a  BGA149 package, and is a <1 GByte (?) 16-bit sdr nand. I could not find a full datasheet for it, I only have a pinout map.

According to the list of supported NAND chips on your web-site, this chip is currently unsupported. However, in the case where a similar configuration of the chip is supported, does your software allow to manually configure the access parameters?

Which programmer should I purchase in order to get support for this NAND chip?

Regards.

回复 1# krz1
T56 Programmer
you can DIY a adapter BGA149 to DIP48.
ZIF48 pins is assigned as ONFI standard(16 bits NAND):
All VCC and VCCQ connected together.
All Vss and VssQ connected together.

TSOP48.jpg
2021-4-18 08:55


then set NAND parameters by the chip's data sheet.Please refer to the T56 user guide  section 10.3

Param.jpg
2021-4-18 08:57

TOP

Thank you.

Can I get the pinout of the t56 socket? I would like to have the less moving parts possible between my chip and the programmer.

Regards.

TOP

Pinout same as in up screen.

TOP

Can this be done with TL866 II Plus as well ? I saw that there is support for 16 bit chips for this programmer with an adapter.

TOP

回复 5# krz1

TL866II not support 16 bits and multiple CE/RBn pins

TOP

Following your advice I have ordered a T56 programmer.

Also I have ordered an ADP-SSO-056-0.8 adapter (the only one TSOP48 I could get with a soldering place) and have made soldered the pins from NAND to adapter according to the following diagram which I have drafted based on the pinout of that adapter.



Now, how would I rearrange the pinout of the programmer in XGpro accordingly?

Thank you.

TOP

回复 7# krz1


  you unable to rearrange the pinout of the programmer. you only DIY a special adapter for your IC

TOP

Ok, so I need to rearrange the pins on the PCB according to the tsop48 pinout above.

TOP

I have rewired my chip to the adapter.

However, the pinout I am using does not provide WP# pin.
How can I find it?

Currently I am getting Bad pins:

Bad Pin On ZIF :19
Bad Pin On ZIF :25
Bad Pin On ZIF :36
Bad Pin On ZIF :37
Bad Pin On ZIF :39
Bad Pin On ZIF :48

One is ZIF19 is WP#.

I have connected one of the Vcc of my chip to PIN12, and the other Vcc of my chip to PIN34.

Other pins are effectively not connected to my chip. Do I need to connect all the VCC\VCCQ between them on the PCB, and all the VSS/VSSQ pins between them on the PCB ? Do I need to wire all the ground pins to the chip as well?

Also I have only one CE#, and only one RY/BY.

TOP

回复 10# krz1
what's the Pinout of your IC?
VCC/VCCQ to ZIF12 and ZIF37
VSS/VSSQ to ZIF13 and ZIF36

Connect all VCC/VCCQ on PCB  
Connect all VSS/VSSQ on PCB

set
disable Pin Detect.

TOP

Thank you!

This is the pinout I have.

I will reconnect VCC and VCCQ as per your instructions. My chip has VCC1 and VCC2 though, but both of them seem to be 1,8V.
And interconnect the vcc-s\vccqs on the board as well as vss\vssq-s.

I think my chip might use the same pinout as this BGA149 chip from ST (see attached), I will try the WP pin from this pinout.
st_pinout.png
Pinout TY0D1211.jpg

TOP

Is the WP# pin mandatory for operation?

TOP

回复 13# krz1
Yes,
WP is a write protection Pins. must be connected.

TOP

Am I supposed to read any data if WP is unconnected? Currently I am getting "00"s including while reading ID.

TOP

回复 15# krz1

ALL VSSF  to GND
all  VDDF  to VCC 1.8V

select a chip model with VCC=1.8V  ,  16bits  TSOP48

TOP

>>> ALL VSSF  to GND

Even if all the Vss are interconnected on the chip?

I note that the first image (st) is not from my chip which was made by Toshiba, but from a chip that has a similar pinout made by ST. Also the ST chip is an MCP, while mine is not. The second diagram is for my chip. The second diagram does not have WP. There is no continuity or resistance on the supposedly WP pin on my chip.

TOP

>> select a chip model with VCC=1.8V

I have tried to connect one time with VCC set to 3.0V. It did not allow me to connect because it did not find several pins.
Still, I am worried whether I could have damaged the chip.

TOP

I have tested all the NC pins with multimeter against ground (one of the Vss pins) and still cannot find the #WP pin.
Maybe it has its own Vss which is not common to all the chip?
Is there some trick? Or maybe I should put a capacitor somewhere?

Currently the chip reads only zeros.

TOP

@admin:

May I send the chip to you for you to try to figure it out?

Regards

TOP

回复 20# krz1

1.There must be an adapter.(or a PCB to test)

2. we can not be able to guarantee  the test,  because no the correct data sheet.

TOP

1. I will add an adapter to which the chip is soldered.
I will still make a couple more tries.

2. Yes I understand.

TOP

Hi, so somebody made for me a proper adapter board (see attached), I have soldered the flash chip, managed to read the ID and some data.

The chip is probably 512 MB judging as the user accessible filesystem is 251 MB.

However, only the first block of data is read. What could be the problem?

Also the user readable strings in the first block are all incorrect.

Could you give some advise on configuration? Current configuration is on screenshot.
0-02-0a-8aac22398aaa8d6a1c3e9ca03a3c4e722517c2105bf000cb98c6a3c140b3db64_65b4c0af.jpg
DSC00080.JPG
unknown.png

TOP

Hi, so somebody made for me a proper adapter board (see attached), I have soldered the flash chip, m ...
krz1 发表于 2022-2-6 11:02



   As an user... have you tried upgrade to latest version of XGpro ?  It seem that you are running 11.6 and 11.81 is already out. Be careful, and try on another computer, to keep everything you are doing now...Hope it helps!
Download Newest XGecu T56/TL866II software(下载最新软件) - 编程器使用与软件下载 - XGecu Programmer Forums - Powered by Discuz!

TOP

The issue of user-readable strings appears to be the difference in little-endian - big-endian.

I will try the new version of xgecu.

TOP

Same with the version 11.81, only the first block is read (everything else is "FFFFF").

Also I have noticed that when you save the custom configuration, the NAND Bus width is always saved as 8 bits (mine is 16 bits). Probably a bug.

TOP

@Albano.Matos I have just noticed that the power supply to my T56 from the USB port is 4.76 Volts. Guess I'll try another port (or maybe some old version of the software).

TOP

@Albano.Matos I have just noticed that the power supply to my T56 from the USB port is 4.76 Volts. G ...
krz1 发表于 2022-2-7 21:45



    Hello:    As an user of T56,                                            I'm surprised, by my own experience, to have such low voltage on usb, and still working,
but this is my opinion. See on help --> about, with T56 connected what is the manufacturing date. If TL866II, isn't so
sensitive. and low power...

ADMIN, hope that new year. bring all, the expected success with this , so new, awesome hardware, and the software. :-)

TOP

4.84 V is the highest I can get.

Also it does this.
Inverted regions of bytes.png

TOP

@Albano.Matos

Manufacture date is 2020-10-28

TOP

回复 30# krz1

阿里旺旺图片20220208162416.jpg
2022-2-8 16:10

TOP

回复  krz1
admin 发表于 2022-2-8 16:10


Probably, I was not clear enough. Only the first block (or "0" on your image) has any significant data.
All the other blocks (1 through 4095) show "FFFFF", that is they are read as empty. This cannot be, as there was at least 64 megabytes of user data on that phone.

TOP

As far as I can tell, this is the correct config.

However it still reads empty space past first block.

Also bug - this custom configuration cannot be saved. It defaults to bus width 8 bits, page size 2048, spare size 64, and page number 4096. Other data is saved.

Config file and dump attached. Config file is either being saved or loaded incorrectly!
Correct config.png

TY00D0021211KC_512@TSOP48.zip (550.56 KB)

TY00D0021211KC_uli.zip (408 Bytes)

TOP

回复 33# krz1

Yes this is a bug ,we will fix it about saving config.

TOP

What about not reading other blocks?

TOP

回复 35# krz1

Read the first block is same with other blocks? just diffrent address.Unless the chip has other restrictions.

The reason can only be analyzed by finding the datasheet of the chip.

TOP

The chip could have other restrictions but I cannot find the datasheet (and I have tried various places, including contacting Toshiba and Kioxia). Anything else I can do or you can do? Anything what could be extracted from the boot-loader which was read?

TOP

An empty chip of the same labeling does allow me to write to it without the WP pin being connected.

And I managed to write up until block #15 (inclusive), after what I get erase error.

And I manage to read the changed data which was written.

Also the correct configuration was indeed 2048/64/64 and not 512/16/64.

What could be the reason of the erase error starting block #16 ?

TOP

Dear admin, any news or ideas?
Was the bug with saving the configuration fixed?

Thank you.

TOP

回复 39# krz1


    saving the configuration  has been fixed in V11.90

TOP

Will you take a look at the chip read\write issue if I send the board and empty chip to you?

If so, please give me an address where to send. Also, you don't need to send it back, as it is an empty chip.

Thank you in advance.

TOP

Dear admin, so, can I send the chip to you?

TOP

回复 42# krz1

no useful! no correct data sheet. I can do  nothing.

TOP

返回列表 回复 发帖